Pages: 1
Posted on 11-29-20, 01:29 pm


Karma: 34
Posts: 7/11
Since: 05-28-18
Basically, the fence Koopas always show up in front of the fences. I don't know what's causing it? (See the bottom Koopa)
Posted on 11-29-20, 02:14 pm
Red Koopa


Karma: 383
Posts: 133/138
Since: 04-26-19
Posted by Joris
Basically, the fence Koopas always show up in front of the fences. I don't know what's causing it? (See the bottom Koopa)

iirc this is a problem with the tileset slot that you are using, the koopa should go behind it only if the fence tile is in the exact same position in the original castle tileset with the fence
_________________________
Join the NSMB Hacking Discord!
Posted on 11-29-20, 06:31 pm
Mariomaster

Karma: 8155
Posts: 1597/1608
Since: 06-09-12
The problem is that the fence Koopas can only go behind 3d graphics. For the Tower/Castle tilesets the climbable fence tiles are replaced with quads that are drawn with the 3d engine.
_________________________
GitHub - Kuribo64 - YouTube
Posted on 11-29-20, 08:00 pm
Giant Goomba
09F911029D74E35BD84156C5635688C0

Karma: 2691
Posts: 1170/1201
Since: 02-12-16
those graphics are in the polygon_unit folder like every other 3D tiles.
_________________________
Nothing to say, so jadnjkfmnjamnfjkldnajfnjkanfjdksan jsdnvj m.

Posted on 11-29-20, 10:14 pm (rev. 2 by Joris on 11-29-20, 10:31 pm)


Karma: 34
Posts: 8/11
Since: 05-28-18
I've been at it for around an hour now, the Koopas show correctly behind the fences but now the tileset is messing up, I replicated everything from the original Tower tilesets but as you can see, it's messed up. The Koopa at the top won't go up or down, and the bottom one (behind the fences!) just spins in place.

EDIT: Disregard this. I had forgotten the most crucial thing, Tile behavior. Oops.
EDIT2: After setting the tile behavior, they show up in front again. I'm extremely confused.
Also, is there a way to remove the conveyor belt animations?
Posted on 12-27-20, 10:10 pm, deleted by RicBent: Wrong plce to ask that.
Pages: 1