Pages: 1
Posted on 08-25-19, 09:30 am


Karma: 2
Posts: 1/2
Since: 08-25-19
This isn't for nsmb but since I am using nsmbe to apply the asm patches and it isn't that active here anyway I thought I could ask this here. Instead I' m romhacking professor layton and the diabolical box.

After many hours of finding the arenaoffset I am 100% sure I got the right value (it's 0201efb8). It's right below a function that looks like OS_GetInitArenaLo and between functions that also look like the arena functions in nsmb.

After finally finding it I wanted to try if it works, I setup the template and deleted all files except print.s. Builded it and nsmbe gave no warnings or errors. But after doing so, Starting the rom resulted in a blank screen on both desmume and no$gba.

Can anyone here say what might be causing this?
Posted on 08-31-19, 11:35 am (rev. 2 by  TheGameratorT on 08-31-19, 11:36 am)
Red Goomba
Who needs a title?

Karma: 178
Posts: 40/41
Since: 07-19-18
NSMBe won't work very well with applying ASM hacks to another game.
I once tried MKDS and it gave the same error.
Posted on 08-31-19, 08:42 pm


Karma: 2
Posts: 2/2
Since: 08-25-19
I ended up making my own asm patch inserter that works with the asm patch template too. It should work with other games as well if you give the right arenaLo offset. It's not finished yet though.
Posted on 09-01-19, 01:28 am
Fuzz Ball
Watched the Endless Eight twice.

Karma: 1976
Posts: 980/982
Since: 02-12-16
SM64DS hackers use NSMBe for ASM hacks. it should work.
_________________________
Nothing to say, so jadnjkfmnjamnfjkldnajfnjkanfjdksan jsdnvj m.

Pages: 1