Pages: 1
Posted on 12-31-19, 09:38 am
Newcomer
A ChromeOS NSMBe user

Karma: 8
Posts: 2/3
Since: 08-12-19
So I want to make a hack with a bit of ASM, but here's the problem. Every time I try to click the "Run 'make' and insert" button, the editor just crashes. This is what it posts in the terminal:

I think this is an issue only on Mono. I tried to do it after installing devkitPro on my Chromebook, but it still doesn't work. It was the Linux version of the terminal and NSMBe is a Windows application. Can anyone please help me find a fix for this, if there is any?
_________________________
I'm making a NSMB hack
Posted on 02-19-20, 11:19 pm (rev. 1 by SKJyannick on 02-19-20, 11:23 pm)
Goomba


Karma: -10
Posts: 25/25
Since: 04-22-19
This error seems to occurres because on Linux CMD doens't exist. So there's no way to fix it, if i'm right.
Posted on 02-20-20, 08:03 pm
Mariomaster

Karma: 7534
Posts: 1530/1536
Since: 06-09-12
Try running NSMBe with wine instead. It provieds a cmd replacement.

I imagine it would be quite a mess though. NSMBe needs devkitPro which needs msys. So you'd basically have to setup Linux simulating Windows simulating Linux

Might be a better idea to install devkitPro in Linux, run make manually and patch out the call to make in NSMBe so that it only inserts.
_________________________
GitHub - Kuribo64 - YouTube
Pages: 1